北大青鸟首页添加收藏网站地图
网站首页 中心简介 课程详解 新闻动态 师资团队 就业中心 学员天地 招生问答 在线报名 技术讲座 证书查询
 2011年招生简章 |  高中生专区 | 白领特招班 | 大学生专区 | 学士后 | 充电\转行 | 电脑实用技术 | 报名须知 学员专访
学员天地
  联系我们
课程老师
张玲老师
周老师
  开班信息

开班时间  班级类型      状态
12月31日 网站开发班   限6座
12月28日 转行充电班   限7座
12月25日 在职充电班   限5座
12月20日 .net开发班   限3座
12月16日 android开发   限4座
12月09日 网络营销班   限2座
12月05日 软件开发    已满

  免费讲座

时间: 周三、周六、周日
地点: 北大青鸟航天桥校区
内容: 黑客攻防、网络安全、软件开发、学士
       后 
       择业 就业 创业
主讲: IT资深专家
电话: 010-51659300 / 88414120

点击查看详情>>
  热门专题
 
 
  热点新闻
·调查显示近四成大学毕业生6个月内离职
·专业技能培训成了许多学生走向社会、实现自
·好专业不一定好就业
·北大青鸟朴实男成为求职典范
·2011年中国大学生最佳雇主榜发布 国企
·高考落榜生该怎么办?学好技术是关键
·北大青鸟航天桥学校专家解读:高考后择校志
·高考填志愿是选择学校重要还是选择专业重要
·关注高考后考生心理,北大青鸟为高考不理想
·高考志愿填报:填的不是专业,是就业

  您的位置:北大青鸟首页 -> 学员天地 -> 教学文章 -> Network

轻送搞定Cisco环境局域网

北大青鸟benet组建维护企业网络所有操作命令 简单的 cisco 的配置命令 我们学校第一本书(ENBM)的所有命令


 
交换机基本模式的进入
---------------------------------------------------------------------
特权模式:en
全局配置模式:conf t
接口模式:interface f0/ #
vlan
数据模式:vlan data
line
模式:line console 0


交换机基本配置命令
----------------------------------------------------------------------
配置主机名
config# hostname + name
使能口令
config# enable password +密码
配置加密使能口令
config# enable secret +密码
配置交换机ip
config# interface vlan 1  vlan号)
config-if# ip address +ip地址 +子网
config-if# no shutdown
配置交换机网关
config# ip default -gateway +ip address


交换机查看命令
------------------------------------------------------------------------
#show run                                           
查看内存配置
#show vlan brief                                         
查看vlan信息
#show mac-address-table                             
查看mac地址
#show cdp                                           
查看相邻设备
#copy running-config startup-config  
#write       保存交换机配置
#erase startup-config                               
恢复交换机出厂默认设置

 

vlan 的配置
-------------------------------------------------------------------------
#vlan database                                      
进入到vlan数据库模式
#vlan +
name +                                   加入vlan号及vlan
config#no vlan +                               删除某一vlan
-------------------------------------------------------------------------
将端口划分到某一vlan
 #               conf t                             
进入到全局模式
config#      int f0/1                            进入某一接口模式
config-if#   sw mo acc                           将这个接口设置为永久非中继模式
config-if#   sw acc vlan +                     将这个接口划分到某个vlan
config-if#   end                                 退出
将多个端口划分到某一个vlan
config# Interface rang f0/1 - 10
config# switch acc vlan +

--------------------------------------------------------------------------
trunk
接口
详解  教科书  207


-------------------------------------------------------------------------

s1
----------------------------------------------------------------------------
>en
#vlan data
vlan)#vlan 5
vlan)#vlan 6
vlan)#exit
#conf t
(config)#hostname s1
s1(config)#int f0/1
s1(config-if)#sw mo acc
s1(config-if)#sw acc vlan 5
s1(config-if)int f0/2
s1(config-if)sw mo ac
s1(config-if)sw ac vlan 6
s1(config-if)int vlan 5
s1(config-if)ip add 10.0.0.1 255.0.0.0
s1(config-if)no sh
s1(config-if)int vlan 6
s1(config-if)ip add 20.0.0.1 255.0.0.0
s1(config-if)no sh
s1(config-if)int f0/3
s1(config-if)sw mo tr
s1(config-if)end

 


s2
--------------------------------------------------------------------
>en
#vlan data
vlan)#vlan 5
vlan)#vlan 6
vlan)#exit
#conf t
(config)#hostname s2
s1(config)#int f0/1
s1(config-if)#sw mo acc
s1(config-if)#sw acc vlan 5
s1(config-if)int f0/2
s1(config-if)sw mo ac
s1(config-if)sw ac vlan 6
s1(config-if)int vlan 5
s1(config-if)ip add 10.0.0.2 255.0.0.0
s1(config-if)no sh
s1(config-if)int vlan 6
s1(config-if)ip add 20.0.0.3 255.0.0.0
s1(config-if)no sh
s1(config-if)int f0/3
s1(config-if)sw mo tr
s1(config-if)end


交换机的配置命令 就是这些了   pc上配置ip  ping测试一下

 

 

 

路由器
------------------------------------------------------------------------------
接口模式几乎和交换的差不多大家自己回顾一下 
(参照教科书258页)

 

路由器总结的主要就是实验命令

 

单臂路由配置
s1
----------------------------------------------------------------------------
en
conf t
int vlan 5
exit
int vlan 6
int f0/2
sw mo ac
sw acc vlan 5
int f0/3
sw mo acc
sw mo vlan 6
int f0/1
sw mo tr

 

r1
--------------------------------------------------------------------------
en
conf t
int f0/0
no sh
int f0/0.1
ip add 10.0.0.1 255.0.0.0
en d 5
int f0/0.2
ip add 20.0.0.1 255.0.0.0
en d 6


end

 

pc上配置ip ping 看看如何?
------------------------------------------------------------

 

 

rip
r1
----------------------------------------

en
conf  t
int f0/0
ip add 10.0.0.1 255.0.0.0
no sh
int f0/1
ip add 30.0.0.1 255.0.0.0
no sh
route rip
network 10.0.0.0
network 30.0.0.0
end

 

 

r2
----------------------------------------------
en
conf  t
int f0/0
ip add 20.0.0.1 255.0.0.0
no sh
int f0/1
ip add 30.0.0.2 255.0.0.0
no sh
route rip
network 20.0.0.0
network 30.0.0.0
end

 

 


单臂加rip

s1
---------------------------------------------------------------------
en
vlan data
vlan 5
vlan 6
exit
conf t
int f0/2
sw mo ac
sw ac vlan 5
int f0/3
sw mo ac
sw ac vlan 6
int f0/1
sw mo tr
end

 

 

s2
-------------------------------------------------------------------------
en
vlan data
vlan 5
vlan 6
exit
conf t
int f0/2
sw mo ac
sw ac vlan 5
int f0/3
sw mo ac
sw ac vlan 6
int f0/1
sw mo tr
end

 


r1
-----------------------------------------------
en
conf  t
int f0/0
no sh
int f0/0.1
en d 5
ip add 10.0.0.1 255.0.0.0
no sh
int f0/0.2
en d 6
ip add 20.0.0.1 255.0.0.0
int f0/1
ip add 30.0.0.1 255.0.0.0
no sh
route rip
network 10.0.0.0
network 20.0.0.0
network 30.0.0.0
end

 

 


r2
------------------------------------------------
en
conf  t
int f0/0
no sh
int f0/0.1
en d 5
ip add 40.0.0.1 255.0.0.0
no sh
int f0/0.2
en d 6
ip add 50.0.0.1 255.0.0.0
int f0/1
ip add 30.0.0.2 255.0.0.0
no sh
route rip
network 40.0.0.0
network 50.0.0.0
network 30.0.0.0
end

 


单臂  rip   

-------------------------------------------------------
s1
-----------------
en
vlan data
vlan 5
vlan 6
exit
conf t
int f0/2
sw mo ac
sw ac vlan 5
int f0/3
sw mo ac
sw ac vlan 6
int f0/1
sw mo tr
end


s2
--------------------------
en
vlan data
vlan 5
vlan 6
exit
conf t
int f0/2
sw mo ac
sw ac vlan 5
int f0/3
sw mo ac
sw ac vlan 6
int f0/1
sw mo tr
end


r1
-----------------------------------------
en
conf  t
int f0/0
no sh
int f0/0.1
en d 5
ip add 10.0.0.1 255.0.0.0
no sh
int f0/0.2
en d 6
ip add 20.0.0.1 255.0.0.0
int f0/1
ip add 30.0.0.1 255.0.0.0
no sh
route rip
network 10.0.0.0
network 20.0.0.0
network 30.0.0.0
end

r2  rip v2
----------------------------------------------
en
conf  t
int f0/0
no sh
int f0/0.1
en d 5
ip add 40.0.0.1 255.0.0.0
no sh
int f0/0.2
en d 6
ip add 50.0.0.1 255.0.0.0
int f0/1
ip add 30.0.0.2 255.0.0.0
no sh
route rip
network 40.0.0.0
network 50.0.0.0
network 30.0.0.0
end

 

 

================================

千万记住 rip v1       rip v2 是不能相互通信的 因为他们是不同的版本 

如果要求 rip v1  v2 通信 

就需要在路由器外接的端口上书入一条命令    ip rip receive version 1 2

这样他向外发送的数据通报 就是 rip v1 v2 通告  那么 不管rip v1 v2 都可以进行 通信了

返回顶部 | 招生简章 | 联系我们 | 乘车路线 | 招聘信息 | 网站地图 | 在线报名
版权所有2004-2009 金领园科技(北京)有限公司 京ICP备09038718号 京公网安备:110108006537号
海淀中心网址:http://www.bjbenet.com 电话:010-51659300 / 88414120
海淀地址:北京海淀区西三环北路甲105号科原大厦B座5层 (首都师范大学东门)